Skip to content
Jun 27 / Greg

HTTP Error 401 – Unauthorized with AWX and Oauth to Servicenow on Cloudflare

So I am running CIQ Ascender which is built from the upstream Ansible AWX project(holler at me if you are looking for support), and to protect it as well as give it an SSL cert I use Cloudflare. This works a treat because my install instantly has a valid cert and all is right with the world…until, that is, I tried to connect Servicenow(SNOW) to Ascender’s API via Oauth. I kept getting an “HTTP Error 401 – Unauthorized” message when trying to grab an Oauth token via the Rest Messages.
I have a couple of blog posts on configuring SNOW integration with AAP if you are interested: Order VMs via SNOW, read SNOW CMDB, write SNOW CMDB.

The fix is to make some adjustments in Cloudflare via Page Rules.
Once in Cloudflare, navigate to the domain in question, then click on the rules menu(from here it defaults to “Page Rules”, which is what we want).
In here create a new rule and fill it out as follows:
URL: https://ciq-ascender.gregsowell.com/api/*
Settings:
– Disable Security
– Browser Integrity Check: Off
– Security Level: Essentially Off
– Cache Level: Bypass

Good luck and happy Oauthing…LOL

Jun 25 / Greg

Fantasy Restaurant Spencer Mirabal

Welcome to the warmup exercise for the Why Am I podcast called “the Fantasy Restaurant.”  In here my guests get to pick their favorite: drink, appetizer, main, sides, and dessert…anything goes.  Spencer builds a good’un with some Joe Joes that take me back to when I was 16, broke, and working at a grocery store LOL.  I hope you enjoy this meal with Spencer. Please share this with a friend and help us grow!
Youtube version here:
If you want to support the podcast you can do so via https://www.patreon.com/whyamipod (this gives you access to bonus content including their Fantasy Restaurant!)
Jun 18 / Greg

Fantasy Restaurant Bill Hammack (Engineer Guy)

Welcome to the warmup exercise for the Why Am I podcast called “the Fantasy Restaurant.” In here my guests get to pick their favorite: drink, appetizer, main, sides, and dessert…anything goes. I could not be more pleased with Bill’s m night shyamalan twist. We start with a whisky and then completely pivot away from food, and on to my favorite subject, people. I hope you enjoy the atmosphere and guest list with Bill. Help us grow by sharing with someone!
Youtube version here:
If you want to support the podcast you can do so via https://www.patreon.com/whyamipod (this gives you access to bonus content including their Fantasy Restaurant!)
Jun 11 / Greg

Why Am I Bill Hammack (Engineer Guy)

Hey everybody, I’m Greg Sowell and this is Why Am I, a podcast where I talk to interesting people and try to trace a path to where they find themselves today.  My guest this go around is Bill Hammack.  You may not recognize his name, but you will never forget his voice…he is the “Engineer Guy.”  Bill is a multi discipline engineer, a professor, an author/contributor to many books, a radio broadcaster, but you really know him from his youtube channel where he has millions of subscribers and even more viewers.  His excitement and sheer delight with figuring out the new mediums makes it plain to see why he does it; not for the money, the accolades, or the views…it’s just another solution for him to engineer and improve LOL.  His grounded approach to social media and video platforms has given me a new perspective to approach my work…which I think is the overall goal…I think he just performed his magic trick on me.  I hope you enjoy this conversation with my favorite hedgehog, Bill. Help us grow by sharing with someone!
Youtube version here:
If you want to support the podcast you can do so via https://www.patreon.com/whyamipod (this gives you access to bonus content including their Fantasy Restaurant!)
Jun 4 / Greg

Why Am I Rob Lawless

Hey everybody, I’m Greg Sowell and this is Why Am I, a podcast where I talk to interesting people and try to trace a path to where they find themselves today.  My guest this go around is Rob Lawless, or as I like to refer to him(a younger, better looking Greg).  Rob is on an adventure to make 10K friends. This mission is so important that he quit the rat race to pursue it full time, and after seven years he’s over halfway there. There are so many parallels between our missions(it’s pretty crazy), that it seems we spend a good bit of the time just comparing notes which is actually pretty interesting for me…in fact I think it’s inspired me to start some public speaking surrounding what I’ve learned…I suppose inspiration is all around us all the time.  I hope you enjoy this chat with Rob. Help us grow by sharing with someone!
Youtube version here:
If you want to support the podcast you can do so via https://www.patreon.com/whyamipod (this gives you access to bonus content including their Fantasy Restaurant!)
May 28 / Greg

Fantasy Restaurant Chuck McCarthy

Welcome to the warmup exercise for the Why Am I podcast called “the Fantasy Restaurant.”  In here my guests get to pick their favorite: drink, appetizer, main, sides, and dessert…anything goes.  Chuck orders everything…and I do mean everything LOL.  I mean, most of it is good, so why not go hog wild in the “whadever you like” restaurant. Please share and help us grow!
Youtube version here:
If you want to support the podcast you can do so via https://www.patreon.com/whyamipod (this gives you access to bonus content including their Fantasy Restaurant!)
Inspired by one of my favorite podcasts: ⁠⁠https://www.offmenupodcast.co.uk/
May 22 / Greg

Using Mikrotik To Discover VLANs

Occasionally I’ll be in an unfamiliar place and I want to plug into a switch and see what VLANs a trunk port will give me(I can also use this on wireless occasionally).
There are many ways to do this, but I figured this is a fairly simple one that doesn’t tax small devices too much.

Mikrotik Config

First thing I did was add a VLAN interface(which is virtual) to the physical interface my resource lives on. In my case it was just WLAN1

I then created a DHCP client interface.

Now that I have that configured I wrote a simple script that will do all the work for me:

1
2
3
4
5
6
7
8
9
10
11
:local i 2
:local x 200
:log info snooping-start
/ip dhcp-client enable [/ip dhcp-client find interface=vlan-wlan-test]
while ($i < $x) do={
  /interface vlan set vlan-wlan-test vlan-id=$i
  :log info "snooping $i"
  :set $i ($i + 1)
  :delay 5000ms
}
/ip dhcp-client disable [/ip dhcp-client find interface=vlan-wlan-test]

Local i is what VLAN ID to start at.
Local x is the high number VLAN ID to stop at.
The idea is this script will enable the DHCP client, set the VLAN interface ID to the low number, sit there for 5 seconds, move to the next VLAN ID, and when it’s done it will disable the DHCP client.
The DHCP client will add an entry to the log if it is able to pull an IP.
So I can fire off the script, come back later and the log will tell me the VLAN ID along with the IP subnet it found there.

Conclusion

So this isn’t the most elegant way to perform the action, but it is pretty simple. It is predicated on the idea that DHCP must be there, so it could be modified to possibly do some snooping on each to find traffic.
Let me know what you would do differently, how would you modify it?
Thanks and happy VLAN finding.