Skip to content
Jul 31 / Greg

Belkin/Netgear Routers And Microsoft – Mikrotik Hotspot

So new Belkin routers will give you serious heartburn on your Mikrotik Hotspots.

In a normal hotspot server, you will hijack all internet traffic until a user either accepts trial access or logs in. This normally works great with any PC/MAC/Router…unless you are using a newer Belkin router.

If a Belkin router can’t connect to the internet it will take you to an internal page saying “Everything is terrible and life is over.” Since it grabs your traffic, it will never allow you to get to the hotspot page…and thus never be able to authenticate.

So when the Belkin boots up and pulls and IP it tries to ping heartbeat.belkin.com. If it is unable to access the site it thinks everything is down. The easiest thing to do is add an ip exclusion:

1
2
/ip hotspot walled-garden ip
add action=accept comment=belkin-router-bypass disabled=no dst-address=67.20.176.130

The routers will be able to reach the internet, and all will be right with the world.

Alternately, and vastly more fun, is to set a DNS entry in the Mikrotik for heartbeat.belkin.com to resolve to 127.0.0.1. This way the router would just ping itself and thus always remain available. This also means that if Belkin were to change the IP that this address resolves to it would continue to work 😛

1
2
/ip dns static
add address=127.0.0.1 name=heartbeat.belkin.com

Justin added Netgear to my list with:

1
2
/ip hotspot walled-garden ip
add action=accept comment=Netgear.com disabled=no dst-address=206.16.44.90

JJ just added Microsoft internet detection bypass:

1
2
3
4
/ip hotspot walled-garden ip
add action=accept comment=WindowsNetDetect disabled=no dst-address=131.107.255.255
/ip hotspot walled-garden
add comment=WindowsNetDetect dst-host=*.msftncsi.com"

2 Comments

leave a comment
  1. Omega-00 / Aug 18 2014

    Now you just need to update it with the ones for Apple’s CNA 🙂

    Also, for the belkin and netgear ones; if you put them in walled-garden IP list then they’ll automagically get whatever IP address the website is pointing to, removing the need for them to be statically set.

    Here’s what I’m working with now:

    /ip hotspot walled-garden ip
    add action=accept disabled=no dst-host=heartbeat.belkin.com
    add action=accept disabled=no dst-host=netgear.com
    /ip hotspot walled-garden
    add action=accept disabled=no dst-host=”*.msftncsi.com”

  2. Greg / Aug 18 2014

    Andrew to the rescueeeeeeee

Leave a Comment

*